Limited US Management Console Availability

Incident Report for Seraphic

Resolved

All systems were recovered and are fully operational
Posted Oct 21, 2025 - 12:25 UTC

Update

The US management console is available, with a limited availability of some of the features, but the core functionality currently works as expected.
Posted Oct 20, 2025 - 21:53 UTC

Investigating

We are experiencing issues with the Seraphic management console in the US region, due to a third party service which was impacted by the AWS outage. All extensions are functioning properly and all endpoints are safe.
We will continue to update as things clear up.
Posted Oct 20, 2025 - 20:41 UTC
This incident affected: US Region (US - Management Console).