Some of the update services for our clients are affected by the global Cloudflare outage

Incident Report for Seraphic

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 16:52 UTC

Update

The earlier degradation affecting some of our update services, specifically those related to new installations, has been fully resolved. Cloudflare has applied a fix, and our systems have been operating normally since that time.

While Cloudflare continues to report residual issues on their status page, we have confirmed that these no longer affect our platform. All services are stable, and no further impact is expected.

This incident is now considered resolved. We will continue to follow the situation until Cloudflare reports full resolution.

Thank you for your patience and understanding.
Posted Nov 18, 2025 - 16:49 UTC

Investigating

Only affecting new installations of the product.
We will update once the Cloudflare issue will be resolved.

https://www.cloudflarestatus.com
Posted Nov 18, 2025 - 14:02 UTC
This incident affected: US Region (US - Updates API) and EU Region (EU - Updates API).